# linstor-server 1.33.0-rc.2 release

**URL:** <https://forums.linbit.com/t/linstor-server-1-33-0-rc-2-release/1079>\
**Category:** Release Announcements\
**Tags:** kubernetes, drbd\
**Created:** [December 1, 2025, 6:58pm UTC](https://forums.linbit.com/t/linstor-server-1-33-0-rc-2-release/1079 "2025-12-01T18:58:48Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![rp9](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/rp9/32/38_2.png) [@rp9](https://forums.linbit.com/u/rp9)\
**Post date:** [December 1, 2025, 6:58pm UTC](https://forums.linbit.com/t/linstor-server-1-33-0-rc-2-release/1079/1 "2025-12-01T18:58:48Z")

</div>

Hi!

Early after the rc1 we found some issues with the new min-io size picker for DRBD and after that and some more testing we were able to fix ~ 17 issues with this rc.

## NOTE

With this release we also announce that we will remove etcd database support with Linstor 1.34.0, until then you will have time to migrate to (SQL or k8s-CRD) databases.

## [1.33.0-rc.2] - 2025-12-01

### Fixed

- AutoSnapshot: Fixed “Keep” property (regression introduced in 1.32.0)
- Fixed bug where clone no longer works with other min-io size than 512
- Fixed bug where “r c” fails with disabled auto-min-io on a 4k block-sized SP
- Clone: cleanup source snapshot if cloning failed
- Clone: mark failed volumes with DELETE flags to allow to delete them afterward
- Fixed --diskless-on-remaining not working with COMBINED nodes
- Fixed unnecessary restart of local DRBD peer right after the resource was created
- ToggleDisk: Added missing free-space check
- Clone: Added missing free-space check
- Fixed very rare AccessToDeletedNode during a node-update from the satellite
- Fixed possible NPE in DrbdLayer.hasMetaData
- If one resource fails during calculating gross/net size, other resources should still be processed
- Check resource size on creation and resize
- Run autohelper.manage tasks after node fullsync (before only on node rc, c, d)
- Autotiebreaker: do not delete tiebereaker if node is not online/fullsynced
- Cleanup clone task on satellite reconnect
- Clone: Fixed race conditions when starting multiple clones at once

[https://pkg.linbit.com//downloads/linstor/linstor-server-1.33.0-rc.2.tar.gz](https://pkg.linbit.com//downloads/linstor/linstor-server-1.33.0-rc.2.tar.gz)

Linstor PPA:  
[https://launchpad.net/~linbit/+archive/ubuntu/linbit-drbd9-stack](https://launchpad.net/~linbit/+archive/ubuntu/linbit-drbd9-stack)

Cheers,

Rene
