# LINSTOR on Proxmox VE Newbie experiences

**URL:** <https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212>\
**Category:** LINSTOR\
**Created:** [August 1, 2024, 11:27pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212 "2024-08-01T23:27:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![fx991](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/fx991/32/61_2.png) [@fx991](https://forums.linbit.com/u/fx991)\
**Post date:** [August 1, 2024, 11:27pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212/1 "2024-08-01T23:27:06Z")

</div>

I worked some years with DRBD 8/9. Now I’m trying LINSTOR. I’ll write some experiences here…

I have a two node Proxmox VE Cluster and installed LINSTOR successfully.

**Typical Newbie Error #1: DRBD 8 loaded instead of DRBD 9**

When I try to migrate an existing VM to the LINSTOR-Storage, I get the following error message in Proxmox:

`TASK ERROR: storage migration failed: API Return-Code: 500. Message: Could not autoplace resource pm-8fb7414f, because: [{"ret_code":-4611686018407201828,"message":"Satellite 'pve01' does not support the following layers: [DRBD]" .... (Hundreds lines more ...)`

_Reason_

DRBD 8 was loaded instead of DRBD 9

_Fix (maybe overcomplex or false):_

1. unload drbd with command `rmmod drbd`
2. load drbd with command `modprobe drbd`
3. check that drbd 9 is loaded with `cat /proc/drbd`. Should look like this:

```auto
version: 9.2.10 (api:2/proto:86-122)
GIT-hash: b92a320cb72a0b85144e742da5930f2d3b6ce30c build by root@cln22-felina, 2024-08-01 22:25:24
Transports (api:21): tcp (9.2.10)

```

1. Recreate initramfs with command `update-initramfs -k all -c`
2. reboot System (to make sure correct module is loaded at system boot)

In this other thread the specification of the system is shown:

> [@Trying to Move VM to LINSTOR Storage: storage migration failed: Source and target image have different sizes](https://forums.linbit.com/t/trying-to-move-vm-to-linstor-storage-storage-migration-failed-source-and-target-image-have-different-sizes/213):
>
> When I try to move a storage of the same VM, I get this error: create full clone of drive scsi0 (lvmlocal01:vm-100-disk-1) NOTICE Trying to create diskful resource (pm-83eb69d4) on (cln21-blabla). drive mirror is starting for drive-scsi0 drive-scsi0: Cancelling block job drive-scsi0: Done. TASK ERROR: storage migration failed: block job (mirror) error: drive-scsi0: Source and target image have different sizes (io-status: ok) Any helpful hint, what is wrong? This is my Server- and LINSTOR c…

---

<div class="post-metadata">

**Author:** ![fx991](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/fx991/32/61_2.png) [@fx991](https://forums.linbit.com/u/fx991)\
**Post date:** [August 1, 2024, 11:51pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212/2 "2024-08-01T23:51:11Z")

</div>

Basic VM Creation on Linstor Storage: **Working Fine**

Speed is quite nice (dedicated 1 Gbe Network link for Linstor).

- Online Storage Moving of existing VM to Linstor: **Not working** (See above linked thread).

- Online Storage Moving of newly created VMs from Linstor to LVM-Storage: **Not working** :

```auto
create full clone of drive scsi0 (linstor01:pm-db982f51_102)
TASK ERROR: storage migration failed: target storage 
is known to cause issues with aio=io_uring (used by current drive)

```

Strange: LVM-Backed other VMs are all using io\_uring. Message does not make sense to me.

- Live Migration to other Node (Linstor Satellite with disk): **Working Fine**

- Cross Cluster Live Migration to another Node: **Working Fine**

- VM Deletion: **Working Fine**

- Cross Cluster Live Migration from another node to local cluster on Linstor Storage: **Working Fine**

- Offline Storage Moving of existing VM to Linstor: **Working fine**

- Offline Storage Moving of newly created VMs from Linstor to LVM-Storage: **Working fine**

---

<div class="post-metadata">

**Author:** ![kermat](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/kermat/32/21_2.png) [@kermat](https://forums.linbit.com/u/kermat)\
**Post date:** [August 2, 2024, 9:32pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212/4 "2024-08-02T21:32:25Z")

</div>

> [@fx991](#):
>
> - Online Storage Moving of existing VM to Linstor: **Not working** (See above linked thread).
> - Online Storage Moving of newly created VMs from Linstor to LVM-Storage: **Not working** :

Oh interesting, I’ve not tried this myself. Do other storage plugins/types support moving VMs between them?

Oops, probably better to follow along in the other post 🙂

---

<div class="post-metadata">

**Author:** ![fx991](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/fx991/32/61_2.png) [@fx991](https://forums.linbit.com/u/fx991)\
**Post date:** [August 4, 2024, 1:49am UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212/5 "2024-08-04T01:49:32Z")

</div>

> [@kermat](#):
>
> Do other storage plugins/types support moving VMs between them?

So far all non-linstor-types I used supported that. (I’m using mostly directory type storages (qcow2). Sometimes zfs and ceph).

I just tried directory storage with linstor and online moving. Moving from linstor to directory storage worked mostly. The one issue I got was, that the deletion after migrating to directory storage was not possible. I got this error:

```auto
drive-scsi0: transferred 11.0 GiB of 11.0 GiB (100.00%) in 2m 51s
drive-scsi0: transferred 11.0 GiB of 11.0 GiB (100.00%) in 2m 52s, ready
all 'mirror' jobs are ready
drive-scsi0: Completing block job...
drive-scsi0: Completed successfully.
drive-scsi0: mirror-job finished
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
trying to acquire cfs lock 'storage-linstor01' ...
cfs-lock 'storage-linstor01' error: got lock request timeout
TASK OK

```

So the source disk could not be deleted and I had to do that manually.

I also could not delete the leftover virtual disk on linstor via GUI, because I got the error message: “Cannot remove this resource because a vm with vmid (vmid of migrated vm) is existing.” That seems to be an precaution check, which does not help that much, because the vm in question is existing, but is no longer using the linstor-resource. I would suggest, that the linstor-plugin should be fixed here, meaning to execute the delete, if the corresponding vm is not configured to use the linstor resource.

So I had to remove the resource from both nodes manually via “linstor resource delete …”.

This behaviour seems to be linked to:

> <https://github.com/LINBIT/linstor-proxmox/issues/55>
>
> Hi!
> When I try to perform more than one concurrent action (moving a disk, cloni…ng a VM...), only one action will be successful.
> Other actions fails with "error: got lock request timeout".
> 
> For example, clone a template twice at the same time.
> First VM
> !\[image\](https://github.com/LINBIT/linstor-proxmox/assets/6932851/796cd65d-ff48-4c80-a65f-dc167ee157de)
> Second VM
> !\[image\](https://github.com/LINBIT/linstor-proxmox/assets/6932851/2e25321d-0064-4054-a14a-f91a0c8f9d91)
> 
> If the second virtual machine is cloned after the "Attempting to create disk resource" state of the first virtual machine completes, the second virtual machine will be cloned successfully.
> 
> How can I fix it?
> 
> PVE Components
> \`\`\`
> proxmox-ve: 7.4-1 (running kernel: 6.2.6-1-pve)
> pve-manager: 7.4-3 (running version: 7.4-3/9002ab8a)
> pve-kernel-6.2: 7.3-8
> pve-kernel-5.15: 7.3-3
> pve-kernel-6.2.6-1-pve: 6.2.6-1
> pve-kernel-5.15.102-1-pve: 5.15.102-1
> pve-kernel-5.15.30-2-pve: 5.15.30-3
> ceph-fuse: 15.2.16-pve1
> corosync: 3.1.7-pve1
> criu: 3.15-1+pve-1
> glusterfs-client: 9.2-1
> ifupdown2: 3.1.0-1+pmx3
> ksm-control-daemon: 1.4-1
> libjs-extjs: 7.0.0-1
> libknet1: 1.24-pve2
> libproxmox-acme-perl: 1.4.4
> libproxmox-backup-qemu0: 1.3.1-1
> libproxmox-rs-perl: 0.2.1
> libpve-access-control: 7.4-2
> libpve-apiclient-perl: 3.2-1
> libpve-common-perl: 7.3-3
> libpve-guest-common-perl: 4.2-4
> libpve-http-server-perl: 4.2-1
> libpve-rs-perl: 0.7.5
> libpve-storage-perl: 7.4-2
> libspice-server1: 0.14.3-2.1
> lvm2: 2.03.11-2.1
> lxc-pve: 5.0.2-2
> lxcfs: 5.0.3-pve1
> novnc-pve: 1.4.0-1
> proxmox-backup-client: 2.3.3-1
> proxmox-backup-file-restore: 2.3.3-1
> proxmox-kernel-helper: 7.4-1
> proxmox-mail-forward: 0.1.1-1
> proxmox-mini-journalreader: 1.3-1
> proxmox-offline-mirror-helper: 0.5.1-1
> proxmox-widget-toolkit: 3.6.3
> pve-cluster: 7.3-3
> pve-container: 4.4-3
> pve-docs: 7.4-2
> pve-edk2-firmware: 3.20221111-2
> pve-firewall: 4.3-1
> pve-firmware: 3.6-4
> pve-ha-manager: 3.6.0
> pve-i18n: 2.11-1
> pve-qemu-kvm: 7.2.0-8
> pve-xtermjs: 4.16.0-1
> qemu-server: 7.4-2
> smartmontools: 7.2-pve3
> spiceterm: 3.2-2
> swtpm: 0.8.0~bpo11+3
> vncterm: 1.7-1
> zfsutils-linux: 2.1.9-pve1
> \`\`\`
> 
> Linstor Components
> \`\`\`
> drbd-dkms 9.2.4-1
> drbd-reactor 1.2.0-1
> linstor-common 1.23.0-1
> linstor-controller 1.23.0-1
> linstor-satellite 1.23.0-1
> linstor-proxmox 7.0.1-1
> \`\`\`

Doing it a second time didn’t show up with the issue described here. seems to be I had a concurrent linstor task when migrating.

* * *

Online moving from directory storage to linstor worked fine.

* * *

Short test with zfs showed the “different sizes problem” as it is there with lvm.

---

<div class="post-metadata">

**Author:** ![fx991](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/fx991/32/61_2.png) [@fx991](https://forums.linbit.com/u/fx991)\
**Post date:** [August 5, 2024, 4:31pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-ve-newbie-experiences/212/6 "2024-08-05T16:31:20Z")

</div>

Fast incremental Backups with Proxmox Backup Server: **Working Fine**
