# Failed create VM on Proxmox with Asynchronous Resource-Group Linstor Storage

**URL:** <https://forums.linbit.com/t/failed-create-vm-on-proxmox-with-asynchronous-resource-group-linstor-storage/492>\
**Category:** Proxmox VE\
**Tags:** drbd\
**Created:** [December 11, 2024, 2:41pm UTC](https://forums.linbit.com/t/failed-create-vm-on-proxmox-with-asynchronous-resource-group-linstor-storage/492 "2024-12-11T14:41:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kopidingin](https://yyz1.discourse-cdn.com/flex003/user_avatar/forums.linbit.com/kopidingin/32/139_2.png) [@kopidingin](https://forums.linbit.com/u/kopidingin)\
**Post date:** [December 11, 2024, 2:41pm UTC](https://forums.linbit.com/t/failed-create-vm-on-proxmox-with-asynchronous-resource-group-linstor-storage/492/1 "2024-12-11T14:41:03Z")

</div>

I try create Resource-Group with Asynchronous mode replica on Linstor with 2 node and 2 replica, every time create VM on Proxmox its error

```auto
TASK ERROR: unable to create VM 100 - API Return-Code: 500.
Message: Could not autoplace resource pm-891b5b4f, because:
[{"ret_code":20185089,"message":"Successfully set property key(s): StorPoolName","obj_refs"{"RscDfn":"pm-891b5b4f"},"created_at":"2024-12-10T15:27:04.350778874+07:00"},
{"ret_code":20185089,"message":"Resource 'pm-891b5b4f' successfully autoplaced on 1 nodes",
"details":"Used nodes (storage pool name): 'uha2 (uha2-disk1)'","obj_refs":{"StoragePool/0/0":"uha2-disk1,LVM_THIN","RscDfn":"pm-891b5b4f","Node/0":"uha2"},"created_at":"2024-12-10T15:27:04.350829582+07:00"},
{"ret_code":4611686018447572992,"message":"Updated pm-891b5b4f DRBD auto verify algorithm to 'crc32c'","obj_refs":{"RscDfn":"pm-891b5b4f"},"created_at":"2024-12-10T15:27:04.350864482+07:00"},
{"ret_code":-4611686018407201818,"message":"(Node: 'uha') Failed to adjust DRBD resource pm-891b5b4f"

```

its nothing error when the Resource-Group on Linstor uses Synchronous mode replica. its properties on Resource-group and Node

```auto
root@uha:~# linstor resource-group list-properties rg-async
╭──────────────────────────────────────────────────╮
┊ Key ┊ Value ┊
╞══════════════════════════════════════════════════╡
┊ DrbdOptions/Net/protocol ┊ A ┊
┊ DrbdOptions/PeerDevice/c-max-rate ┊ 4194304 ┊
┊ DrbdOptions/auto-add-quorum-tiebreaker ┊ false ┊
╰──────────────────────────────────────────────────╯

```

```auto
root@uha:~# linstor node list-properties uha
╭───────────────────────────╮
┊ Key ┊ Value ┊
╞═══════════════════════════╡
┊ CurStltConnName ┊ default ┊
┊ NodeUname ┊ uha ┊
┊ Site ┊ a ┊
╰───────────────────────────╯

```

---

<div class="post-metadata">

**Author:** ![rck](https://avatars.discourse-cdn.com/v4/letter/r/c37758/32.png) [@rck](https://forums.linbit.com/u/rck)\
**Post date:** [December 11, 2024, 3:22pm UTC](https://forums.linbit.com/t/failed-create-vm-on-proxmox-with-asynchronous-resource-group-linstor-storage/492/2 "2024-12-11T15:22:07Z")

</div>

yes, that is known.

In order to move VMs we need to allow dual primary, which means for a very short time the disk is Primary on the source node and on the destination node. This is fine as long as only one node write to the disk. Proxmox/qemu makes sure of that.

This dual primary mode is only allowed in DRBD for DRBD protocol C.

So if we want to be able to move VMs, then we need DRBD protocol C. If you are one of the very few people that never ever want to move VMs, where it would be okay to have protocol A, then you are out of luck: The plugin supports protocol C only.
