# Cloudstack hci cluster install problem

**URL:** https://forums.linbit.com/t/cloudstack-hci-cluster-install-problem/571
**Category:** LINBIT SDS Integrations
**Tags:** linstor, cloudstack
**Created:** [January 24, 2025, 3:10pm UTC](https://forums.linbit.com/t/cloudstack-hci-cluster-install-problem/571 "2025-01-24T15:10:41Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![elocatelli](https://avatars.discourse-cdn.com/v4/letter/e/f17d59/32.png) [@elocatelli](https://forums.linbit.com/u/elocatelli)
#### Post date: [January 24, 2025, 3:10pm UTC](https://forums.linbit.com/t/cloudstack-hci-cluster-install-problem/571/1 "2025-01-24T15:10:41Z")

</div>

Hi,

We are trying to setup a test cluster with 3 physical nodes, using: LINBIT Clo  
udStack HCI version 1.3.0-rc.2.cloudstack.

The nodes have dual network card (fiber channel 10GBs) , we configured a bond network and over that a vlan specific for this nodes.

All the nodes can reach each other, they are able to reach the gw and are accesible remotly using ssh.

When we start the cluster config, the installation fails:

“rpc error: code = Unknown desc = failed to configure cloudstack management: exit status 9”

I have downloaded the logs and no further information is available, this is the only file containing an error ouput.

"Command line:  
linstor-appliance --version  
Exit code: 0  
Output:  
linstor-appliance version 1.3.0-rc.2.cloudstack  
Product: LINBIT CloudStack HCI (cloudstack)  
Built at Mon Dec 23 10:55:40 UTC 2024  
Version control hash: v1.3.0-rc.2  
Error Output:  
time=“2025-01-24T11:55:34-03:00” level=info msg=“Read config from /etc/linstor-appliance/linstor-appliance.toml”

Please let me know if you need more details. We are excited to test this environment but we are stuck.

Regards,

Enzo

---

<div class="post-metadata">

### Author: ![mpb](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@mpb](https://forums.linbit.com/u/mpb)
#### Post date: [January 25, 2025, 2:12am UTC](https://forums.linbit.com/t/cloudstack-hci-cluster-install-problem/571/2 "2025-01-25T02:12:12Z")

</div>

Hi, You can try this Quick Intro from youtube to start with…

[![](https://canada1.discourse-cdn.com/flex003/uploads/linbit/original/1X/deb7c70e2177c4377bde1517303481aadc0bccb7.jpeg "Setup LINSTOR with Cloudstack") ](https://www.youtube.com/watch?v=hI_kTlsbNeU)

---

<div class="post-metadata">

### Author: ![elocatelli](https://avatars.discourse-cdn.com/v4/letter/e/f17d59/32.png) [@elocatelli](https://forums.linbit.com/u/elocatelli)
#### Post date: [January 27, 2025, 1:40pm UTC](https://forums.linbit.com/t/cloudstack-hci-cluster-install-problem/571/3 "2025-01-27T13:40:57Z")

</div>

Hi Thank you for your help. In this case the problem was the file /etc/cloudstack/management/db.properties , the ip of one of the nodes was pointing to a non existing ip.

Also if you update linux packages of the hosts servers using yum, the new kernel does not includes the drbd library.

So I have reinstalled the OS on all the nodes and started from the scratch, my cluster is working now!!

Regards,

Enzo
