# LINBIT SDS Integrations

**URL:** https://forums.linbit.com/c/linbit-sds-integrations/7.md

[Latest](https://forums.linbit.com/latest.md) · [Categories](https://forums.linbit.com/categories.md) · [Tags](https://forums.linbit.com/tags.md)

---

## [About the LINBIT SDS Integrations category](https://forums.linbit.com/t/about-the-linbit-sds-integrations-category/18)

<div class="topic-metadata">

**Author:** [@michael](https://forums.linbit.com/u/michael)\
**Replies:** 0

</div>

LINBIT SDS is the combined DRBD and LINSTOR software stack. LINBIT SDS integrates with many platforms such as Kubernetes, Proxmox VE, OpenNebula, CloudStack, and others. Use this category to discuss these integrations. Y…

---

## [Trying to secure the drbd-network of proxmox cluster](https://forums.linbit.com/t/trying-to-secure-the-drbd-network-of-proxmox-cluster/688)

<div class="topic-metadata">

**Author:** [@youzersef](https://forums.linbit.com/u/youzersef)\
**Replies:** 8\
**Last updated:** [September 12, 2026, 10:07pm UTC](https://forums.linbit.com/t/trying-to-secure-the-drbd-network-of-proxmox-cluster/688 "2026-09-12T22:07:48Z")

</div>

Hello everybody, am trying to secure the drbd. i have used this guide: security-best-practices-for-linstor-software-defined-storage-clusters i stucked on the point Securing the LINSTOR Controller’s REST API i can no…

---

## [Linstor property on Openstack volume types](https://forums.linbit.com/t/linstor-property-on-openstack-volume-types/1225)

<div class="topic-metadata">

**Author:** [@joalmodo](https://forums.linbit.com/u/joalmodo)\
**Replies:** 1\
**Last updated:** [August 28, 2026, 7:20am UTC](https://forums.linbit.com/t/linstor-property-on-openstack-volume-types/1225 "2026-08-28T07:20:48Z")

</div>

Hi, in a openstack cloud with LINSTOR, i want to create a volume type with the linstor property “DrbdOptions/Disk/al-extents” set to 6007. This is what shows in openstack volume type section: volume\_backend\_name linstor…

---

## [Satellite pods keep running after fatal error](https://forums.linbit.com/t/satellite-pods-keep-running-after-fatal-error/1259)

<div class="topic-metadata">

**Author:** [@damo](https://forums.linbit.com/u/damo)\
**Replies:** 1\
**Last updated:** [August 25, 2026, 1:44pm UTC](https://forums.linbit.com/t/satellite-pods-keep-running-after-fatal-error/1259 "2026-08-25T13:44:45Z")

</div>

When running up a LinstorCluster and when the nodes do not have the drbd module, the pods start ok. Viewing the logs can see error (“modprobe: FATAL: Module drbd not found in directory”): 2026-08-19 09:35:32.217 \[Device…

---

## [LinstorCluster clean up and writes to node /var folders](https://forums.linbit.com/t/linstorcluster-clean-up-and-writes-to-node-var-folders/1260)

<div class="topic-metadata">

**Author:** [@damo](https://forums.linbit.com/u/damo)\
**Replies:** 1\
**Last updated:** [August 25, 2026, 1:42pm UTC](https://forums.linbit.com/t/linstorcluster-clean-up-and-writes-to-node-var-folders/1260 "2026-08-25T13:42:58Z")

</div>

When running up piraeus operator I got a list of errors by running the linstor error-reports command on the linstor controller. After completely removing the LinstorCluster and the piraeus operator and then redeploying, …

---

## [Proxmox snapshot backup of containers fails sometimes](https://forums.linbit.com/t/proxmox-snapshot-backup-of-containers-fails-sometimes/1134)

<div class="topic-metadata">

**Author:** [@espenu](https://forums.linbit.com/u/espenu)\
**Replies:** 5\
**Last updated:** [August 17, 2026, 5:32pm UTC](https://forums.linbit.com/t/proxmox-snapshot-backup-of-containers-fails-sometimes/1134 "2026-08-17T17:32:54Z")

</div>

My setup has two storage nodes, each with 2x nvme drives mirrored with mdadm, an lvm on that, and then drbd. In addition I have a VM running on TrueNAS as a diskless witness. The two storage nodes are connected with a d…

---

## [Linstor plugin outdated?](https://forums.linbit.com/t/linstor-plugin-outdated/1221)

<div class="topic-metadata">

**Author:** [@pme242](https://forums.linbit.com/u/pme242)\
**Replies:** 5\
**Last updated:** [June 24, 2026, 7:36am UTC](https://forums.linbit.com/t/linstor-plugin-outdated/1221 "2026-06-24T07:36:31Z")

</div>

Since the last Proxmox Update V9.1.14 the following message appears for migration tasks: Plugin “PVE::Storage::Custom::LINSTORPlugin” is implementing an older storage API, an upgrade is recommended Where to find the up…

---

## [DRBD & Proxmox 7.0 kernel](https://forums.linbit.com/t/drbd-proxmox-7-0-kernel/1216)

<div class="topic-metadata">

**Author:** [@pme242](https://forums.linbit.com/u/pme242)\
**Replies:** 4\
**Last updated:** [May 11, 2026, 9:27am UTC](https://forums.linbit.com/t/drbd-proxmox-7-0-kernel/1216 "2026-05-11T09:27:58Z")

</div>

Hi, I’ve learned last time the hard way that I shouldn’t install asap a new kernel if I’m using drbd :smiling\_face\_with\_sunglasses: Any info about support of drbd 9 for the new proxmox 7.0 kernel? Thanks in advance.

---

## [Resizing stuck on Proxmox 9.1.6 / DRBD 9.3.1](https://forums.linbit.com/t/resizing-stuck-on-proxmox-9-1-6-drbd-9-3-1/1184)

<div class="topic-metadata">

**Author:** [@sayso](https://forums.linbit.com/u/sayso)\
**Replies:** 7\
**Last updated:** [April 6, 2026, 6:15pm UTC](https://forums.linbit.com/t/resizing-stuck-on-proxmox-9-1-6-drbd-9-3-1/1184 "2026-04-06T18:15:33Z")

</div>

Hi all, I have a brand new installation that is working well except for volume resizing. I used the Proxmox GUI to do the resize and the size incremented as expected, but linstor volume list and linstor vd l do not matc…

---

## [Resources stuck in "Connecting"](https://forums.linbit.com/t/resources-stuck-in-connecting/1104)

<div class="topic-metadata">

**Author:** [@DavidMac](https://forums.linbit.com/u/DavidMac)\
**Replies:** 14\
**Last updated:** [January 17, 2026, 1:40am UTC](https://forums.linbit.com/t/resources-stuck-in-connecting/1104 "2026-01-17T01:40:16Z")

</div>

I have a three node Proxmox cluster and am using Linstor for storage across the three. Each node had a direct connection to the other two (for replication), as well as a main connection to my network. I’ll show this la…

---

## [CloudStack 4.22 – VM deployment on LINSTOR primary fails during ROOT volume population (qemu-img convert), while volume creation succeeds](https://forums.linbit.com/t/cloudstack-4-22-vm-deployment-on-linstor-primary-fails-during-root-volume-population-qemu-img-convert-while-volume-creation-succeeds/1122)

<div class="topic-metadata">

**Author:** [@bilalinamdar](https://forums.linbit.com/u/bilalinamdar)\
**Replies:** 4\
**Last updated:** [January 8, 2026, 8:02am UTC](https://forums.linbit.com/t/cloudstack-4-22-vm-deployment-on-linstor-primary-fails-during-root-volume-population-qemu-img-convert-while-volume-creation-succeeds/1122 "2026-01-08T08:02:16Z")

</div>

sos report Download sos\_2026-01-02\_15-03-28.tar.gz | LimeWire Architecture ┌──────────────────────────────────┐ │ Management Node │ │ …

---

## [Error: “Satellite … does not support the following layers: \[DRBD\]” when creating VM on LINSTOR storage in Proxmox](https://forums.linbit.com/t/error-satellite-does-not-support-the-following-layers-drbd-when-creating-vm-on-linstor-storage-in-proxmox/1116)

<div class="topic-metadata">

**Author:** [@LgAltair](https://forums.linbit.com/u/LgAltair)\
**Replies:** 5\
**Last updated:** [January 5, 2026, 5:54pm UTC](https://forums.linbit.com/t/error-satellite-does-not-support-the-following-layers-drbd-when-creating-vm-on-linstor-storage-in-proxmox/1116 "2026-01-05T17:54:03Z")

</div>

Hey everyone, I installed LINSTOR on a three-node Proxmox cluster. All nodes are identical, each with the same type of NVMe drives and connected via 25 Gb mesh network. I followed the official guide here: https://linbi…

---

## [Ancient DRBD after Proxmox update until headers are installed manually](https://forums.linbit.com/t/ancient-drbd-after-proxmox-update-until-headers-are-installed-manually/1069)

<div class="topic-metadata">

**Author:** [@sewi](https://forums.linbit.com/u/sewi)\
**Replies:** 3\
**Last updated:** [November 25, 2025, 8:20pm UTC](https://forums.linbit.com/t/ancient-drbd-after-proxmox-update-until-headers-are-installed-manually/1069 "2025-11-25T20:20:21Z")

</div>

Hey there, This is the second time it happened, and I’m wondering if there’s anything I should be doing. Basically, I’m on a Linbit staff performed install of DRBD/LINSTOR, running Proxmox 9. I update Proxmox (pveupdat…

---

## [Opennebula 7 / Linbit CE (linstor-client 1.27.0) Issue](https://forums.linbit.com/t/opennebula-7-linbit-ce-linstor-client-1-27-0-issue/1066)

<div class="topic-metadata">

**Author:** [@hoosain](https://forums.linbit.com/u/hoosain)\
**Replies:** 1\
**Last updated:** [November 21, 2025, 1:35pm UTC](https://forums.linbit.com/t/opennebula-7-linbit-ce-linstor-client-1-27-0-issue/1066 "2025-11-21T13:35:54Z")

</div>

Import image from marketplace to DS intel\_image : eg Ubuntu 22.04 Image gets downloaded to KVM - I can see it in linstor resource list. eg intel1/intel2/amd2 instantiate a VM and deploy to intel1 - no issues i…

---

## [Storage Pool creation not working](https://forums.linbit.com/t/storage-pool-creation-not-working/1059)

<div class="topic-metadata">

**Author:** [@clemone210](https://forums.linbit.com/u/clemone210)\
**Replies:** 1\
**Last updated:** [November 16, 2025, 8:19pm UTC](https://forums.linbit.com/t/storage-pool-creation-not-working/1059 "2025-11-16T20:19:20Z")

</div>

Hello together, in my homelab I wanted to try out Linstor with Proxmox. I successfully created the satellites and a controller as well as the gui. Created the nodes and created two storage pools from a new disk as LVM-…

---

## [Integration with openstack](https://forums.linbit.com/t/integration-with-openstack/1048)

<div class="topic-metadata">

**Author:** [@mojtabashg](https://forums.linbit.com/u/mojtabashg)\
**Replies:** 5\
**Last updated:** [November 12, 2025, 2:28pm UTC](https://forums.linbit.com/t/integration-with-openstack/1048 "2025-11-12T14:28:59Z")

</div>

Hello Linstor Community, We are a cloud computing provider currently using OpenStack with a Ceph backend. To achieve higher throughput and lower latency for our block storage, we are seriously evaluating Linstor + DRBD …

---

## [PVE Cluster broken after update](https://forums.linbit.com/t/pve-cluster-broken-after-update/1038)

<div class="topic-metadata">

**Author:** [@Avocado](https://forums.linbit.com/u/Avocado)\
**Replies:** 1\
**Last updated:** [November 6, 2025, 3:27pm UTC](https://forums.linbit.com/t/pve-cluster-broken-after-update/1038 "2025-11-06T15:27:12Z")

</div>

I have a three node proxmox cluster with DRBD+LINSTOR accordign to the official instructions. I had upgraded the cluster to PVE 9 and changed the repo files as per instructions to match Proxmox 9. This was successful and…

---

## [Linstor Gateway on Kubernetes](https://forums.linbit.com/t/linstor-gateway-on-kubernetes/395)

<div class="topic-metadata">

**Author:** [@AlexandreM](https://forums.linbit.com/u/AlexandreM)\
**Replies:** 4\
**Last updated:** [November 6, 2025, 2:31pm UTC](https://forums.linbit.com/t/linstor-gateway-on-kubernetes/395 "2025-11-06T14:31:54Z")

</div>

Hello What is the best way to install the linstor gateway? I see many examples with linux package managers. Is it possible to do that on either piraeus or the linstor operator for a Kubernetes environment?

---

## [Unsupported type 'drbd'](https://forums.linbit.com/t/unsupported-type-drbd/496)

<div class="topic-metadata">

**Author:** [@sewi](https://forums.linbit.com/u/sewi)\
**Replies:** 3\
**Last updated:** [October 30, 2025, 3:24pm UTC](https://forums.linbit.com/t/unsupported-type-drbd/496 "2025-10-30T15:24:33Z")

</div>

DRBD is working fine here on Proxmox as long as I just do stuff such as creating VMs, migrating them manually. However, when Proxmox HA manager tries to do something with the VMs, I get messages such as Dec 11 13:21:21…

---

## [Disk setup advice](https://forums.linbit.com/t/disk-setup-advice/227)

<div class="topic-metadata">

**Author:** [@svh1985](https://forums.linbit.com/u/svh1985)\
**Replies:** 6\
**Last updated:** [October 18, 2025, 1:17pm UTC](https://forums.linbit.com/t/disk-setup-advice/227 "2025-10-18T13:17:54Z")

</div>

Hi there! I’m setting up a new PVE cluster and looking for some best practices advice on the disk setup. I have 3 identical HPE servers all fitted with Smart Array P440ar Raid controllers and 8 SSD disks. As I see the…

---

## [Linstor on Proxmox utilising NVMe-of with RDMA over RoCE](https://forums.linbit.com/t/linstor-on-proxmox-utilising-nvme-of-with-rdma-over-roce/893)

<div class="topic-metadata">

**Author:** [@st.louey](https://forums.linbit.com/u/st.louey)\
**Replies:** 9\
**Last updated:** [September 28, 2025, 3:24pm UTC](https://forums.linbit.com/t/linstor-on-proxmox-utilising-nvme-of-with-rdma-over-roce/893 "2025-09-28T15:24:49Z")

</div>

Hi Everyone, This is my first post to the forum after sucssefully configuring Linstor on a 2 node Proxmox cluster. I would now like to optimse the networking by implementing NVMe-of with RDMA over RoCE utilsiing Mellan…

---

## [Resource UpToDate but The Size is different](https://forums.linbit.com/t/resource-uptodate-but-the-size-is-different/978)

<div class="topic-metadata">

**Author:** [@ahim](https://forums.linbit.com/u/ahim)\
**Replies:** 17\
**Last updated:** [August 29, 2025, 2:27am UTC](https://forums.linbit.com/t/resource-uptodate-but-the-size-is-different/978 "2025-08-29T02:27:39Z")

</div>

Hi, I am just setup proxmox cluster with 3 node, use linstor as storage backend with 3 replica, and create some VM with linstor storage backend. I install linstor gui as well. However, when I see a resource from linstor…

---

## [Debian 13 / Proxmox 9 packages at the horizon?](https://forums.linbit.com/t/debian-13-proxmox-9-packages-at-the-horizon/964)

<div class="topic-metadata">

**Author:** [@Ariston](https://forums.linbit.com/u/Ariston)\
**Replies:** 6\
**Last updated:** [August 8, 2025, 1:04pm UTC](https://forums.linbit.com/t/debian-13-proxmox-9-packages-at-the-horizon/964 "2025-08-08T13:04:28Z")

</div>

First of all, I’d like to thank you guys for providing this piece of software. Coming from the vSAN (v)Sphere I was not impressed by Ceph on a small scale and LINSTOR turns out to be the perfect bang for my slightly date…

---

## [See LINSTOR and Proxmox in Action on Linus Tech Tips!](https://forums.linbit.com/t/see-linstor-and-proxmox-in-action-on-linus-tech-tips/249)

<div class="topic-metadata">

**Author:** [@Ryan](https://forums.linbit.com/u/Ryan)\
**Replies:** 2\
**Last updated:** [July 26, 2025, 12:30pm UTC](https://forums.linbit.com/t/see-linstor-and-proxmox-in-action-on-linus-tech-tips/249 "2025-07-26T12:30:13Z")

</div>

Hi Everyone, We want to give a quick shout-out to Jake and everyone at Linus Tech Tips (LTT) for featuring LINSTOR in one of their latest videos: This was a fun highlight from last week. LINSTOR was a gre…

---

## [LINSTOR does not appear in Proxmox/Datacenter GUI](https://forums.linbit.com/t/linstor-does-not-appear-in-proxmox-datacenter-gui/929)

<div class="topic-metadata">

**Author:** [@rafaelrdealmeida](https://forums.linbit.com/u/rafaelrdealmeida)\
**Replies:** 1\
**Last updated:** [July 22, 2025, 10:34pm UTC](https://forums.linbit.com/t/linstor-does-not-appear-in-proxmox-datacenter-gui/929 "2025-07-22T22:34:22Z")

</div>

I’m using Linstor LVM-THIN on 5 Proxmox nodes (I have more nodes), but it doesn’t appear in the datacenter. I can even add it as LVM-THIN, but, for example, moving disks to it doesn’t appear in Linstor. Does anyone know …

---

## [Unnecessary resource is created when the satellite is turned off](https://forums.linbit.com/t/unnecessary-resource-is-created-when-the-satellite-is-turned-off/923)

<div class="topic-metadata">

**Author:** [@pikulinka](https://forums.linbit.com/u/pikulinka)\
**Replies:** 2\
**Last updated:** [July 22, 2025, 4:54pm UTC](https://forums.linbit.com/t/unnecessary-resource-is-created-when-the-satellite-is-turned-off/923 "2025-07-22T16:54:49Z")

</div>

Hello everyone. I noticed such a feature that when the satellite service is stopped on the second node in a cluster of two nodes, then when trying to create a disk through proxmox, a resource without a replica is created…

---

## [Trying to install Linstor on 3-node Proxmox Cluster 8.3.3 but unable to get sources](https://forums.linbit.com/t/trying-to-install-linstor-on-3-node-proxmox-cluster-8-3-3-but-unable-to-get-sources/906)

<div class="topic-metadata">

**Author:** [@jsalinas](https://forums.linbit.com/u/jsalinas)\
**Replies:** 2\
**Last updated:** [July 16, 2025, 10:25pm UTC](https://forums.linbit.com/t/trying-to-install-linstor-on-3-node-proxmox-cluster-8-3-3-but-unable-to-get-sources/906 "2025-07-16T22:25:07Z")

</div>

Hi, i just found your product & site and found a blog post on setting it up with proxmox ve but have not been able to even get started as none of the links to apt sources work. can someone please point me in the right d…

---

## [Quorum lost when performing multiple clones](https://forums.linbit.com/t/quorum-lost-when-performing-multiple-clones/815)

<div class="topic-metadata">

**Author:** [@kreeuwijk](https://forums.linbit.com/u/kreeuwijk)\
**Replies:** 5\
**Last updated:** [July 11, 2025, 12:35pm UTC](https://forums.linbit.com/t/quorum-lost-when-performing-multiple-clones/815 "2025-07-11T12:35:06Z")

</div>

When we use Linstor (Piraeus) as storage for Kubevirt, we are seeing a weakness specifically when cloning PVCs. If multiple new VMs are created that perform a CSI-assisted clone of a golden image PVC, we can see triggeri…

---

## [Installed Linstor per documentation but Proxmox fails to create a Linstor Resource](https://forums.linbit.com/t/installed-linstor-per-documentation-but-proxmox-fails-to-create-a-linstor-resource/845)

<div class="topic-metadata">

**Author:** [@tc1210id](https://forums.linbit.com/u/tc1210id)\
**Replies:** 4\
**Last updated:** [June 11, 2025, 1:54pm UTC](https://forums.linbit.com/t/installed-linstor-per-documentation-but-proxmox-fails-to-create-a-linstor-resource/845 "2025-06-11T13:54:51Z")

</div>

Running Proxmox 8.4.1 When I create a VM on linstor\_storage, I get the following error: NOTICE Trying to create diskful resource (pm-e3770bd4) on (pm-01-20210914). Diskfull assignment on pm-01-20210914 failed, let…

---

## [Is it possible to set up a Linstor-DRBD-Cluster (for Proxmox) with initially only one node available?](https://forums.linbit.com/t/is-it-possible-to-set-up-a-linstor-drbd-cluster-for-proxmox-with-initially-only-one-node-available/449)

<div class="topic-metadata">

**Author:** [@inside](https://forums.linbit.com/u/inside)\
**Replies:** 2\
**Last updated:** [May 3, 2025, 12:17pm UTC](https://forums.linbit.com/t/is-it-possible-to-set-up-a-linstor-drbd-cluster-for-proxmox-with-initially-only-one-node-available/449 "2025-05-03T12:17:16Z")

</div>

Hi there, the question from the topic title is nearly complete: Is it possible to set up a Linstor-DRBD-Cluster (for Proxmox) with initially only one node available? (Second/third) node later to join.) If yes, how wo…

[Next page](https://forums.linbit.com/c/linbit-sds-integrations/7.md?page=1)
